Rails/Ubuntu - Cannot build mysql gem?

If you saw the "Failed to build gem native extension" error while building native mysql gem then you need to install libmysql++-dev package.

$ sudo gem install mysql
[sudo] password for milosz: 
Fetching: mysql-2.8.1.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing mysql:
	ERROR: Failed to build gem native extension.
[...]
$ sudo apt-get install libmysql++-dev
$ sudo gem install mysql
Building native extensions.  This could take a while...
Successfully installed mysql-2.8.1
1 gem installed
Installing ri documentation for mysql-2.8.1...
Installing RDoc documentation for mysql-2.8.1...
Milosz Galazka's Picture

About Milosz Galazka

Milosz is a Linux Foundation Certified Engineer working for a successful Polish company as a system administrator and a long time supporter of Free Software Foundation and Debian operating system.

Gdansk, Poland https://sleeplessbeastie.eu