Mikrotik - How to send logs to remote server

Just two simple steps - create logging action and rule.

First step

Define action (set action name, remote server IP address, syslog parameters):

/system logging action
add bsd-syslog=yes name=remote_server_x remote=10.23.23.1 remote-port=514 \
    src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=\
    remote

Second step

Define rule (use action created in the first step, specify desired topics):

/system logging
add action=remote_server_x disabled=no prefix="" topics=system,!snmp,!ntp
Milosz Galazka's Picture

About Milosz Galazka

Milosz is a system administrator working for a successful Polish company and a long time supporter of Free Software Foundation and Debian operating system.

Gdansk, Poland https://sleeplessbeastie.eu