Categories
SysOps

How to display RabbitMQ version

Display RabbitMQ/Erlang version using essential utilities.

RabbitMQ diagnostics

Use rabbitmq-diagnostics to display the RabbitMQ version.

$ sudo rabbitmq-diagnostics server_version
Asking node rabbit@buster for its RabbitMQ version...
3.7.18

Use rabbitmq-diagnostics to display the Erlang version.

$ sudo rabbitmq-diagnostics erlang_version
Asking node rabbit@buster for its Erlang/OTP version...
Erlang/OTP 22.1

Erlang

Use Erlang to display the RabbitMQ version.

$ sudo rabbitmqctl eval "rabbit_misc:version()."
"3.7.18"

Use Erlang to display the OTP release number.

$ sudo rabbitmqctl eval "rabbit_misc:otp_release()."
"22.1"

Use Erlang to display the emulator version.

$ sudo rabbitmqctl eval "erlang:system_info(version)."
"10.5"

Display detailed Erlang run-time version.

$ sudo rabbitmqctl eval "erlang:system_info(system_version)."
"Erlang/OTP 22 [erts-10.5] [source] [64-bit] [smp:2:2] [ds:2:2:10] [async-threads:64]\n"

System packages

Display erlang-base version.

$ apt-cache policy erlang-base
erlang-base:
  Installed: 1:22.1-1
  Candidate: 1:22.1-1
  Version table:
 *** 1:22.1-1 500
        500 https://dl.bintray.com/rabbitmq-erlang/debian buster/erlang-22.x amd64 Packages
        100 /var/lib/dpkg/status
     1:22.0.7-1 500
        500 https://dl.bintray.com/rabbitmq-erlang/debian buster/erlang-22.x amd64 Packages
     1:22.0.6-1 500
        500 https://dl.bintray.com/rabbitmq-erlang/debian buster/erlang-22.x amd64 Packages
     1:22.0-1 500
        500 https://dl.bintray.com/rabbitmq-erlang/debian buster/erlang-22.x amd64 Packages
     1:21.2.6+dfsg-1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages

Display rabbitmq-server version.

$ apt-cache policy rabbitmq-server
rabbitmq-server:
  Installed: 3.7.18-2
  Candidate: 3.7.18-2
  Version table:
 *** 3.7.18-2 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     3.7.18-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.17-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.16-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.15-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.14-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.13-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.12-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.11-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.10-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.9-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.8-4 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
     3.7.8-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.7-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.6-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.5-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.4-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.3-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.2-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.1-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.7.0-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.6.16-2 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.6.16-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages
     3.6.15-1 500
        500 https://dl.bintray.com/rabbitmq/debian stretch/main amd64 Packages

References